Dismiss Notice
Welcome to Our Community
Wanting to join the rest of our members? Feel free to sign up today.

table is not loading correctly

Discussion in 'Programming' started by prober, May 5, 2008.

  1. prober

    prober New Member Webmaster

    I use the tutorial´s instructions and try to load data into the client table with this command...
    load data local infile 'c:/mysql/client.txt' into table client;

    the table is populated but it´s missing some of the first letters of the first column. what´s wrong?
  2. prober

    prober New Member Webmaster

    mora info..with this problem

    ok these are the records in the text file I created to load into the mysql table..(using notepad, writing records immediatly at the begining of notepad editor and separating each element with a tab space )

    Fluffy 1995-05-15 litter 4 kittens, 3 female, 1 male
    Buffy 1993-06-23 litter 5 puppies, 2 female, 3 male
    Buffy 1994-06-19 litter 3 puppies, 3 female
    Chirpy 1999-03-21 vet needed beak straightened
    Slim 1997-08-03 vet broken rib
    Bowser 1991-10-12 kennel /N
    Fang 1991-10-12 kennel /N
    Fang 1998-08-28 birthday Gave him a new chew toy
    Claws 1998-03-17 birthday Gave him a new flea collar
    Whistler 1998-12-09 birthday First birthday

    I load them into the table and when I try to see them with select * from
    it shows the table incomplete missing letters from the elements of the first column.....gives me no error whatsoever... i'm puzzled.

    as far as i have worked with this database only once has it worked properly, but since that time always is the same problem, using load data local infile gives me an incomplete table...:-(
  3. Shadow Stewart

    Shadow Stewart New Member Webmaster

    if table is not correctly loading then check the codes for connecting
  4. Shadow Stewart

    Shadow Stewart New Member Webmaster

    make sure your table is available on the selected location
  5. maneetpuri

    maneetpuri New Member Webmaster


    What is the saperator you are defining for records is it "\n", if yes try to make it "\n\r" and in your text file make sure that youhave hit the enter key after every record while creating the text file.

    Also you can try to use field delimiter as something else than space and try it.

    As if you are able to see the table and the data i don't think its the problem of connectivity or location.

    Also something character set can lead to this problem, in the table you have created try to set the chactaerest set to utf-general and then try to load the data.



Featured Resources (View All)

Share This Page